Home > MAIL, Microsoft Exchange, Windows Server > DELETED MAILBOX NOT APPEARING IN DISCONNECTED MAILBOXES IN EXCHANGE 2010

DELETED MAILBOX NOT APPEARING IN DISCONNECTED MAILBOXES IN EXCHANGE 2010

Here are a couple of very simple commands that allow to force the clean up of mailboxes databases in Exchange 2010. It happens sometimes that when you delete a mailbox, it does not show up in the “Disconnected Mailboxes” container. This usually happens if the Exchange Online Maintenance has not run yet. Now, you may wait for it, but when it is critical that your user get the mailbox back, these commands might come very handy.

The first command is :

Clean-MailboxDatabase DatabaseName

Note: The previous command will only clean up that one mailbox database that you specified.

To Clean up all your databases at one, you can pipe the previous command to another command called: Get-MailboxDatabase.

Your final command should look like :

Get-MailboxDatabase | Clean-MailboxDatabase

About these ads
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 65 other followers

%d bloggers like this: